Cloudflare outage is causing widespread system services failures
Resolved·Partial outage

The widespread Cloudflare outage that was impacting our payment partners has been resolved. Payment processing is now functioning normally. We are continuing to monitor the stability of all dependent services.

Tue, Nov 18, 2025, 03:15 PM
(2 weeks ago)
·
Affected components
Web App
API
Updates

Resolved

The widespread Cloudflare outage that was impacting our payment partners has been resolved. Payment processing is now functioning normally. We are continuing to monitor the stability of all dependent services.

Tue, Nov 18, 2025, 03:15 PM

Identified

Payment processing is currently experiencing delays due to the ongoing, widespread Cloudflare outage affecting our third-party payment partners. We are monitoring the situation closely.

Tue, Nov 18, 2025, 02:12 PM(1 hour earlier)